3 solutions pour avertir les utilisateurs d’IE6 que leur navigateur est obsolete

ie6-blocker

Je propose aujourd’hui non pas une, non pas deux mais bien 3 solutions pour bloquer Internet Explorer 6. Car oui, il y a encore trop de personnes qui utilisent cette bouse ancienne version d’Internet Explorer (IE6 date de 2001). Version, qui en plus d’avoir des failles de sécurité, ne respecte pas les standards du web… Un designer/intégrateur doit bosser 2 fois plus (sans gagner plus) pour adapter les sites sour IE6.

Je pourrais en parler longtemps, mais ce n’est pas le sujet du jour. Une des solutions pour aider à faire baisser IE6 dans les stastistiques serait d’avertir les utilisateurs que la version du navigateur de Microsoft qu’ils utilisent est obsolète (pour rappel on en est à la version 8 actuellement). Dans mes recherches, j’ai trouvé 3 solutions :

ie6-blocker2

1/ IE6 Upgrade Warning :

Ce script JavaScript à insérer simplement dans tes pages HTML, permet de signaler aux utilisateur d’IE6 que leur navigateur est dépassé et de proposer directement des liens pour aller télécharcher soit la dernière version d’IE soit un navigateur alternatif. L’affichage de la boîte d’avertissement se fait en plein milieu de la page et est bien styilisé de base

2/ IE6 Blocker Script :

Css-tricks propose tout un tutorial pour afficher un message d’avertissement. Le tutorial utilise le JavaScript, JQuery et le CSS. Tout y est bien expliqué, mais si tu veux aller plus vite, tu peux téléchager tous les fichiers d’exemples présentés.

3/ Shockingly Big IE6 Warning :

Shockingly Big IE6 Warning est en fait un plugin pour WordPress. Il propose trois niveaux de réglages pour le message d’avertissement :

  • un message discret (quoique) tout en heut de la page (mais en jaune fluo)
  • une page complète (qu’on ne peut donc pas louper) avant d’arriver sur le contenu
  • le crash complet d’IE6… :twisted:

Pas encore de billet sur le même sujet !

Cette entrée a été publiée dans navigateurs web, avec comme mot(s)-clef(s) , . Vous pouvez la mettre en favoris avec ce permalien.

Une reponse a 3 solutions pour avertir les utilisateurs d’IE6 que leur navigateur est obsolète

  1. kronos dit :

    pas mal mais ca risque pas de faire pas a de aux visiteurs ? xd

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *

Vous pouvez utiliser ces balises et attributs HTML : <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong> <pre lang="" line="" escaped="" highlight="">